Delays Processing EUR SEPA Instant Payments

Incident Report for Kraken

Identified

The issue has been identified and a fix is being implemented.
Posted May 19, 2026 - 17:48 UTC

Investigating

We are aware of an ongoing scheme-wide incident impacting the processing of SEPA Instant Payments. Outgoing EUR SEPA payments may be affected and remain in a pending processing status until the incident is resolved.

We are actively monitoring the situation with our provider and will share further updates as more information becomes available.
Posted May 19, 2026 - 11:58 UTC
This incident affects: Payment Methods (Euro (EUR) - Instant).