Orders Visibility Issue

Incident Report for Kraken

Identified

The issue has been identified and a fix is being implemented.
Posted May 19, 2026 - 11:44 UTC

Investigating

We are investigating an issue causing order history to be unavailable for orders placed from May 13 onwards. We are working to resolve the issue and will update as soon as we have more information.
Posted May 19, 2026 - 07:43 UTC